Defender-DeviceProcessEvents › Event 9001000

Event ID 9001000 — Process activity (any)

Provider
Defender-DeviceProcessEvents
Channel
DeviceProcessEvents

Description

Process activity (any)

Fields #

NameDescription
DeviceId
DeviceName
Timestamp
ActionType
FileName
FolderPath
SHA1
SHA256
MD5
ProcessId
ProcessCommandLine
AccountName
AccountDomain
InitiatingProcessFileName
InitiatingProcessFolderPath
InitiatingProcessSHA256
InitiatingProcessCommandLine
InitiatingProcessAccountName
InitiatingProcessAccountDomain
InitiatingProcessParentFileName

Detection Patterns #

26 rules

Detection Rules #

View all rules referencing this event →

Kusto Query Language # view in reference

  • SUNBURST suspicious SolarWinds child processes source medium: Identifies suspicious child processes of SolarWinds.Orion.Core.BusinessLayer.dll that may be evidence of the SUNBURST backdoor References: - https://www.fireeye.com/blog/threat-research/2020/12/evasive-attacker-leverages-solarwinds-supply-chain-compromises-with-sunburst-backdoor.html - https://gist.github.com/olafhartong/71ffdd4cab4b6acd5cbcd1a0691ff82f

References #