Defender-DeviceProcessEvents

ActionTypeTitleSampleRule
anyProcess activityYY
ProcessCreatedProcess createdYY
OpenProcessProcess handle openedNN

any: Process activity

#
Table
DeviceProcessEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete event schema.

NameRulesVendors
InitiatingProcessFileName33 detection rulesKusto
FileName32 detection rulesKusto
ProcessCommandLine28 detection rulesKusto
InitiatingProcessCommandLine17 detection rulesKusto
InitiatingProcessParentFileName9 detection rulesKusto
FolderPath6 detection rulesKusto
ActionType4 detection rulesKusto
ProcessIntegrityLevel4 detection rulesKusto
AccountName3 detection rulesKusto
InitiatingProcessFolderPath2 detection rulesKusto
ProcessVersionInfoOriginalFileName2 detection rulesKusto
SHA12 detection rulesKusto
SHA2562 detection rulesKusto
DeviceName1 detection ruleKusto
InitiatingProcessSHA2561 detection ruleKusto

Example Event #

{
  "AccountDomain": "nt authority",
  "AccountName": "network service",
  "AccountSid": "S-1-5-20",
  "ActionType": "ProcessCreated",
  "CreatedProcessSessionId": 0,
  "CreatedProcessSessionId@odata.type": "#Int64",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "FileName": "MpCmdRun.exe",
  "FileSize": 1893920,
  "FileSize@odata.type": "#Int64",
  "FolderPath": "C:\\ProgramData\\Microsoft\\Windows Defender\\Platform\\4.18.26060.3008-0\\MpCmdRun.exe",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "system",
  "InitiatingProcessAccountSid": "S-1-5-18",
  "InitiatingProcessCommandLine": "\"MsMpEng.exe\"",
  "InitiatingProcessCreationTime": "2026-08-01T00:56:40.6829454Z",
  "InitiatingProcessFileName": "msmpeng.exe",
  "InitiatingProcessFileSize": 290704,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\programdata\\microsoft\\windows defender\\platform\\4.18.26060.3008-0\\msmpeng.exe",
  "InitiatingProcessId": 4580,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessLogonId": 0,
  "InitiatingProcessLogonId@odata.type": "#Int64",
  "InitiatingProcessMD5": "bfa930edc3aea262d3a74e71263f6e41",
  "InitiatingProcessParentCreationTime": "2026-08-01T00:56:34.7240107Z",
  "InitiatingProcessParentFileName": "services.exe",
  "InitiatingProcessParentId": 1084,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "d94df701fb5f2e89d902e8bcef19b8d52a12b65a",
  "InitiatingProcessSHA256": "35979bf35eea166dd17d81b50ceae41043e4ae1082f4ed25383adffd9d88de4a",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessSignatureStatus": "Valid",
  "InitiatingProcessSignerType": "OsVendor",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184873058",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Antimalware Service Executable",
  "InitiatingProcessVersionInfoInternalFileName": "MsMpEng.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "MsMpEng.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "4.18.26060.3008",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "IsProcessRemoteSession": 0,
  "IsProcessRemoteSession@odata.type": "#SByte",
  "LogonId": 996,
  "LogonId@odata.type": "#Int64",
  "MD5": "50748135411ab2227a961757d96fb456",
  "ProcessCommandLine": "\"MpCmdRun.exe\" GetDeviceTicket -AccessKey 3474F9D5-96F4-6236-8080-E8299426B055 ",
  "ProcessCreationTime": "2026-08-01T09:19:44.5639533Z",
  "ProcessId": 10356,
  "ProcessId@odata.type": "#Int64",
  "ProcessIntegrityLevel": "System",
  "ProcessTokenElevation": "TokenElevationTypeDefault",
  "ProcessUniqueId": "9851624184879170",
  "ProcessVersionInfoCompanyName": "Microsoft Corporation",
  "ProcessVersionInfoFileDescription": "Microsoft Malware Protection Command Line Utility",
  "ProcessVersionInfoInternalFileName": "MpCmdRun",
  "ProcessVersionInfoOriginalFileName": "MpCmdRun.exe",
  "ProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "ProcessVersionInfoProductVersion": "4.18.26060.3008",
  "ReportId": 14402,
  "ReportId@odata.type": "#Int64",
  "SHA1": "b92bf73d510217422e180fd7a09dafe6410f90e0",
  "SHA256": "556d0de327089f436d461486b953a97dbd26c458c2c4f01d59d6d4217025cf26",
  "Timestamp": "2026-08-01T09:19:44.570542Z"
}

Detection Patterns #

Show All Detection Patterns

Common Indicators #

Positive field/value combinations most frequently checked by detection rules targeting this event, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
file_name (kusto rule field)eqpowershell.exe3 ruleskusto
file_name (kusto rule field)incmd.exe4 ruleskusto
file_name (kusto rule field)inat.exe3 ruleskusto
file_name (kusto rule field)inbitsadmin.exe3 ruleskusto
file_name (kusto rule field)incertutil.exe3 ruleskusto
file_name (kusto rule field)incmstp.exe3 ruleskusto
file_name (kusto rule field)incscript.exe3 ruleskusto
file_name (kusto rule field)ininstallutil.exe3 ruleskusto
file_name (kusto rule field)inmavinject.exe3 ruleskusto
file_name (kusto rule field)inmsbuild.exe3 ruleskusto
file_name (kusto rule field)inmshta.exe3 ruleskusto
file_name (kusto rule field)inmsiexec.exe3 ruleskusto
ActionType (kusto rule field)eqInboundConnectionAccepted3 ruleskusto
ActionType (kusto rule field)eqprocesscreated3 ruleskusto
IntegrityLevel (kusto rule field)eqHigh3 ruleskusto

Detection Rules #

Full rule details for this event, including ATT&CK technique mappings and native queries →

Kusto #

ProcessCreated: Process created

#
Table
DeviceProcessEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete event schema.

NameRulesVendors
ActionType8 detection rulesKusto
FileName4 detection rulesKusto
InitiatingProcessCommandLine3 detection rulesKusto
FolderPath2 detection rulesKusto
InitiatingProcessFileName2 detection rulesKusto
InitiatingProcessParentFileName2 detection rulesKusto
InitiatingProcessSHA11 detection ruleKusto
ProcessCommandLine1 detection ruleKusto
ProcessVersionInfoOriginalFileName1 detection ruleKusto
SHA11 detection ruleKusto

Example Event #

{
  "AccountDomain": "nt authority",
  "AccountName": "network service",
  "AccountSid": "S-1-5-20",
  "ActionType": "ProcessCreated",
  "CreatedProcessSessionId": 0,
  "CreatedProcessSessionId@odata.type": "#Int64",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "FileName": "MpCmdRun.exe",
  "FileSize": 1893920,
  "FileSize@odata.type": "#Int64",
  "FolderPath": "C:\\ProgramData\\Microsoft\\Windows Defender\\Platform\\4.18.26060.3008-0\\MpCmdRun.exe",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "system",
  "InitiatingProcessAccountSid": "S-1-5-18",
  "InitiatingProcessCommandLine": "\"MsMpEng.exe\"",
  "InitiatingProcessCreationTime": "2026-08-01T00:56:40.6829454Z",
  "InitiatingProcessFileName": "msmpeng.exe",
  "InitiatingProcessFileSize": 290704,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\programdata\\microsoft\\windows defender\\platform\\4.18.26060.3008-0\\msmpeng.exe",
  "InitiatingProcessId": 4580,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessLogonId": 0,
  "InitiatingProcessLogonId@odata.type": "#Int64",
  "InitiatingProcessMD5": "bfa930edc3aea262d3a74e71263f6e41",
  "InitiatingProcessParentCreationTime": "2026-08-01T00:56:34.7240107Z",
  "InitiatingProcessParentFileName": "services.exe",
  "InitiatingProcessParentId": 1084,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "d94df701fb5f2e89d902e8bcef19b8d52a12b65a",
  "InitiatingProcessSHA256": "35979bf35eea166dd17d81b50ceae41043e4ae1082f4ed25383adffd9d88de4a",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessSignatureStatus": "Valid",
  "InitiatingProcessSignerType": "OsVendor",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184873058",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Antimalware Service Executable",
  "InitiatingProcessVersionInfoInternalFileName": "MsMpEng.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "MsMpEng.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "4.18.26060.3008",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "IsProcessRemoteSession": 0,
  "IsProcessRemoteSession@odata.type": "#SByte",
  "LogonId": 996,
  "LogonId@odata.type": "#Int64",
  "MD5": "50748135411ab2227a961757d96fb456",
  "ProcessCommandLine": "\"MpCmdRun.exe\" GetDeviceTicket -AccessKey 3474F9D5-96F4-6236-8080-E8299426B055 ",
  "ProcessCreationTime": "2026-08-01T09:19:44.5639533Z",
  "ProcessId": 10356,
  "ProcessId@odata.type": "#Int64",
  "ProcessIntegrityLevel": "System",
  "ProcessTokenElevation": "TokenElevationTypeDefault",
  "ProcessUniqueId": "9851624184879170",
  "ProcessVersionInfoCompanyName": "Microsoft Corporation",
  "ProcessVersionInfoFileDescription": "Microsoft Malware Protection Command Line Utility",
  "ProcessVersionInfoInternalFileName": "MpCmdRun",
  "ProcessVersionInfoOriginalFileName": "MpCmdRun.exe",
  "ProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "ProcessVersionInfoProductVersion": "4.18.26060.3008",
  "ReportId": 14402,
  "ReportId@odata.type": "#Int64",
  "SHA1": "b92bf73d510217422e180fd7a09dafe6410f90e0",
  "SHA256": "556d0de327089f436d461486b953a97dbd26c458c2c4f01d59d6d4217025cf26",
  "Timestamp": "2026-08-01T09:19:44.570542Z"
}

Detection Patterns #

Common Indicators #

Positive field/value combinations most frequently checked by detection rules targeting this event, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
ActionType (kusto rule field)eqprocesscreated6 ruleskusto
ActionType (kusto rule field)eqProcessCreated2 ruleskusto
ActionType (kusto rule field)eqConnectionSuccess1 rulekusto
ActionType (kusto rule field)eqFileRenamed1 rulekusto
ActionType (kusto rule field)eqListeningConnectionCreated1 rulekusto
ActionType (kusto rule field)eqNamedPipeEvent1 rulekusto
GlobalPrevalence (kusto rule field)is_null1 rulekusto
GlobalPrevalence (kusto rule field)lt2002 ruleskusto
GlobalPrevalence (kusto rule field)lt1001 rulekusto
GlobalPrevalence (kusto rule field)lt2501 rulekusto
sha1 (kusto rule field)is_not_null2 ruleskusto
DestinationPort (kusto rule field)in3891 rulekusto
DestinationPort (kusto rule field)in6361 rulekusto
IsCertificateValid (kusto rule field)ne11 rulekusto
OriginalFileName (kusto rule field)eqbrowsercore.exe1 rulekusto

Detection Rules #

Full rule details for this event, including ATT&CK technique mappings and native queries →

Kusto #

OpenProcess: Process handle opened

#
Table
DeviceProcessEvents

References #